uva 489

In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

  1. The contestant tries to solve to puzzle by guessing one letter at a time.
  2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
  3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once. 


   ______   
   |  |     
   |  O     
   | /|    
   |  |     
   | /     
 __|_       
 |   |______
 |_________|



  4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
  5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
  6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.
You lose.
You chickened out.

Sample Input

1
cheese
chese
2
cheese
abcdefg
3
cheese
abcdefgij
-1

Sample Output

Round 1
You win.
Round 2
You chickened out.
Round 3
You lose.

水题还wa.真是药丸.药丸啊...

/*************************************************************************
	> File Name: code/uva/489.cpp
	> Author: 111qqz
	> Email: rkz2013@126.com 
	> Created Time: 2015年09月23日 星期三 19时34分34秒
 ************************************************************************/

#include<iostream>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<stack>
#include<cctype>
#define y1 hust111qqz
#define yn hez111qqz
#define j1 cute111qqz
#define ms(a,x) memset(a,x,sizeof(a))
#define lr dying111qqz
using namespace std;
#define For(i, n) for (int i=0;i<int(n);++i)  
typedef long long LL;
typedef double DB;
const int inf = 0x3f3f3f3f;
const int N=30;
int a[N];
int main()
{
  #ifndef  ONLINE_JUDGE 
   freopen("in.txt","r",stdin);
  #endif
    int cas;
    while (scanf("%d",&cas)!=EOF)
    {
	if (cas==-1) break;
	ms(a,0);
	printf("Round %d\n",cas);
	
	string st1,st2;
	cin>>st1>>st2;
	int len1 = st1.length();
	for ( int i = 0 ; i < len1 ; i++)
	{
	    int tmp = st1[i]-'a';
	    a[tmp]++;
	}
	int len2 = st2.length();
	int cnt = 0 ;
	int sum = 0 ;
	int state = 0;
	for ( int i = 0 ; i < len2 ; i++)
	{
	    int tmp = st2[i]-'a';
	    if (a[tmp]==0)
	    {
		cnt++;
	    }
	    else
	    {
		sum += a[tmp];
		a[tmp] =  0;
	    }
	    if (cnt>=7) break;
	    if (sum==len1)
	    {
		state = 1;
		break;
	    }
	}
	if (state ==1)
	{
	    puts("You win.");
	    continue;
	}
//	cout<<"cnt:"<<cnt<<endl;
	if (cnt<7)
	{
	    puts("You chickened out.");
	}
	else
	{
	    puts("You lose.");
	}
    }
   
 #ifndef ONLINE_JUDGE  
  fclose(stdin);
  #endif
	return 0;
}